KB2920189が適用できない

少しはまったのでメモ代わりに。

KB2920189を適用しようとすると、一部の仮想マシンでどうしても800F0922のエラーコードで成功しない事がありました。

無題1

無題2

なぜ特定VMだけかなと、思っていたのですが切り分けしてみるとHyper-Vの第二世代で作成したVMのみ失敗します。

解決するには、VMを一度シャットダウンし、Hyper-Vのファームウェアの設定から[セキュアブートを有効にする]のチェックを外し、Windows Updateを実行します。

 

無題3

無事インストールできました。無題4 無題5

さて、第2世代をプロダクション環境で利用開始してもいいものか…。もう少しノウハウ蓄積してからにしようか悩み中。

あ、もちろんアップデートが終わった後はファームウェアの設定を元に戻しておきましょう。

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中